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Lab GPIO_35
GPIOの使い方

プロジェクトの別名セーブ
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補足:
Workspaceと
Projectの関係

演習ファイルと使用文字などの注意事項

•各演習プロジェクトを置くための演習用ディレクトリを作成して
ください。場所と名前は、演習中に指示します。(デフォルトは、
C:¥PSoC5_Lab )
•設計例(正解の例)プロジェクトは、演習で指示する場所の
PSoC_Lab_MasterXXXXにあります。
•使用するファイルのあるディレクトリのパス名に英数字以外の
文字が含まれていないことを確認してください。(不可例参照)
•ファイル名、プログラムのソースには、英数字と構文で許され
た記号以外は使用しないでください。(不可例参照)
•WorkspaceとProjectを1対1に対応して作成(次スライド)

•不可例:全角文字、日本語文字、半角カナ
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演習プロジェクト作成のグランドルール

•設計は、プロジェクトをひとつの単位としますが、大規模設計では複数のプ
ロジェクトをまとめて、ひとつのWorkspace内で管理することができます。

•複数のプロジェクトを一つのWorkspaceに追加した場合、同じ名前のファイ
ルを開いたときに、どのプロジェクトに含まれるものなのかを毎回確認する
必要があります。例えば main.c などです。
•ワークショップ中は、この混乱をさけるために、一つのWorkspace には一
つのプロジェクトしか配置しないように注意して下さい。

•この方法は三つあります。
•1.新プロジェクトを作成する前に、一度現在のPSoC Creatorを閉じる
•2.プロジェクト作成する前に、FileメニューからClose Workspaceを実行し
て現在開いているWorkspaceを閉じる
•3.新規プロジェクトを作成する時、Advancedオプション内のWorkspaceを
Create New Workspaceに設定する。この方法については次のページに説
明があります。
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プロジェクト新規作成時の注意事項
•プロジェクトを既に開いた状態で新規プロジェクトを作成した場合、デフォルトでは、
現在開いているWorkspaceに追加されます。ウィザード内のWorkspaceをCurrent 
New Workspaceに切り替えて下さい。

Advancedオプションを
オープンする

Add to Current Workspaceを選択
すると
現在開いているWorkspace内に
新規プロジェクトが作成されます。
Create New Workspaceを選択する
と、
新規Workspaceが作成され、
その中に新規プロジェクトが作成され
ます。
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GPIO_35ラボの目的
• GPIOのハードウェア単独制御(MPU不使用) (GPIO_35D)

• GPIOのポーリング制御(MPU使用) (GPIO_35P)

• GPIOの割込み制御(MPU使用) (GPIO_35I)

• プロジェクトの別名でのセーブ法 (GPIO_35D -> GPIO_35P変更)

• プロジェクトの内容
– GPIO_３５D スイッチを押すとLEDが消灯 離すと点灯

– GPIO_３５P / GPIO_35I スイッチを押すとLEDが点灯 離すと消灯

GPIO_35D

PSoC3/5

P0[5] LEDSW2 (P6_1)

GPIO_35P
(GPIO_35I)

PSoC3/5

SW2 (P6_1) P0[5] LED
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Step 1: PSoC Creator Softwareの起動

Step 2: 新しいプロジェクトの作成

Step 3: コンポーネントの追加

Step 4: コンポーネントのコンフィギュレーション

Step 5: コンポーネントの接続

Step 6:共有リソースの設定

Step 7:ソースコードの記述

Step 8: Build と Debug

全体の処理フローの解説
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Step 1 PSoC Creator Softwareの起動

1.PSoC Createrの起動は、
>すべてのプログラム>Cypress
>PSoC Creater 2.X> PSoC Createrのクリック。2.この

エリアに
ファイルが
ないことを
確認する
こと

前のプロ
ジェクトが
表示される
場合は、

File>Close 
Workspace
でクローズ
する。
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各ウィンドウの解説

ウィンドウ番号 機能

1,Main Window 回路の表記、ピンアサイン、コードの記述などを行います。Work space exploreから開いたものが、メイン
ウィンドウに表示されます。立ち上がった状態(画面の状態)ではSchimatic Windowが表示され回路の表
記Windowが表示されています。機能ごとに TAB形式で開かれ、TABが二つ以上ある場合にはTABを
右クリックしてNew XXX windowを選択することで縦、横に分割することもできます。

2,Work Space Explore SourceTABにはプロジェクトに必要なファイルが表示されます。また、ここから既存のファイルを追加する
なども可能です。Componentsには自分で作成したモジュールなどのファイルが表示されます。Resultに
は各種ログファイルが表示されます。

3,Component Catalog 標準ではCypress社の用意したモジュールが表示されます。コンポーネントのデータシートなども、ここから
参照できます。

4,Output 現在進行中のLogファイルがここに表示されます。コンパイル結果なども同様に、Output Windowに表示
されます。

画面が見つからない場合等は、
Window > Reset Layoutを実行



© Renji Mikami – 2012 PSoC 5 / 3 CUA Workshop 

Step 2新しいプロジェクトの作成

•File->New->Projectを選択してください
•Project名は、GPIO_35D等にしてください
•Locationは、演習で指示しますが、デフォルトは、
C:¥PSoC5_Labとします。
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Step 2.1 新規プロジェクトの作成(続き)
2.Empty PSoC5 Design を選択(ハイライト化)

3.Nameの欄に,GPIO_35D
と 名前をつける(名前は任意)

4.プロジェクトの置き場所を指定
(演習で指示の全英文字パスディレクトリ

デフォルトは、C:¥PSoC5_Lab)

6.OKをクリック

5.デバイス指定または変更の場合は、ここから選択(次ページ)

1.+ マークをクリック
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Device Selector デバイスの選択や変更
このアイコンをクリックすると、

表示するフィルタ項目を設定できます

フィルタ項目を選択することで、
必要な機能を搭載した
PSoC を抽出できます

オンライン版もあります
http://www.cypress.com/?id=2232

CY8C-KIT-050 実装デバイスは、
CY8C5588-AXI-060です。
デバイスリビジョン はここで選択できます。
ここから適切ものを選択して下さい

2011年Q4 時点では、ES1です。
使用するコンポーネントには、バージョ
ンがあり、デバイスリビジョンに対応す
るバージョンを選択してください。
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エディタ画面の切り替え
選択ファイルによって、エディタの構成が変化

Workspace Explorer

ソースコードエディタ
拡張子 *.c等

共有リソースエディタ
拡張子 *.cydwr

回路図エディタ
拡張子 *.cysch
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Step 3 コンポーネントの追加
1.TopDesign.cyshをクリック(回路図を開く)

2.Port and Pins > Digital Input Pinをドラッグ
して移動,回路図にドロップ(配置)

設定ウインドウ
コマンド ショートカット

拡大 Ctrl + クリック

範囲拡大 Ctrl + ドラッグ

縮小 Ctrl + Shift + クリック

範囲縮小 Ctrl + Shift + ドラッグ

パン(画面移動) Alt + ドラッグ

3.下記のコマンドを使用して、
回路図を拡大して下さい
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Step 4 コンポーネントのコンフィギュレーション

回路図上のPin_1を
右クリックしConfigureを選択
し設定ウインドウを開く
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Step 4.1 コンポーネントの設定1

各項目の意味
Name: コンポーネントインスタンスの名称
Analog : アナログ入出力用
Digital Input : デジタル入力用
HW Connection : 内部のデジタルバスへ接続
Digital Output : デジタル出力用
HW Connection :内部のデジタルバスへ接続
Output Enable : IOをトライステートIOに設定
Bidirectional : IOを双方向に

内部デジタルバスへ接続
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Step 4.2 コンポーネントの設定2

Name を “SW” に変更
コンポーネント毎のAPIはこの名称をもとに
生成されるので、わかりやすい名前を付けること。
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Step 4.3 コンポーネントの設定3
①Pins > General の Drive Modeを
Resistive Pull Downに設定して下さい。

IOに内蔵している
プルアップ/ダウン抵抗は約5kΩ です。

①Pins > General の Drive Modeを
Resistive Pull Downに設定して下さい。

IOに内蔵している
プルアップ/ダウン抵抗は約5kΩ です。

各項目の解説
Drive Mode : IOの入出力モード
詳細についてはTRM 22.I/O Systemを参照

Initial State : POR解除後のIO出力の初期状態
Drive ModeをPull Up/Downで使用する場合、
Pull Downの場合は”0”
Pull Upの場合は”1” に設定する必要があります

②設定が終わったらOKをクリック
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Step 4.4 コンポーネントの追加

コマンド ショートカット

拡大 Ctrl + クリック

範囲拡大 Ctrl + ドラッグ

縮小 Ctrl + Shift + クリック

範囲縮小 Ctrl + Shift + ドラッグ

パン(画面移動) Alt + ドラッグ

Component Catalogから次のコンポーネントを
Editor画面にDrag & Drop して下さい
•Ports and Pins

• Digital Outupt Pin x 1

画面操作コマンド
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Step 5 コンポーネントの接続
①“Wire Tool” を使用して
二つのコンポーネントを結線して下さい

不要な配線は、選択し、Delete キー を
押すことで削除できます

②コンポーネントの接続ボックスが
消えたことを確認して下さい。
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Step 5.1 コンポーネントの設定

②Name を “LED” に変更して下さい。
コンポーネント毎のAPIはこの名称をもとに
生成されますので、わかりやすい名前を

つけてください。
変更が終わったらOKボタンを押して下さい

①コンポーネント Pin_1をダブルクリック
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共有リソースエディタ(.cydwr画面から選択)
•PSoC Creatorでは、デバイスの固有リソースの割り当てを行うために共有リソース
エディタが用意されています。.cydwr画面を表示して画面下のタブを選択することで、
表示する画面の切り替えを行います。

IO管理画面IO管理画面 クロックリソース管理画面クロックリソース管理画面

割り込み優先度管理画面割り込み優先度管理画面
DMA優先度管理画面DMA優先度管理画面

Pins Clocks

Interrupts DMA
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Step 6 共有リソースの設定

GPIO_35D.cydwr をダブルクリックして開いて下さい
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Step 6.1   IOのアサイン

SWをP6[1] に割り当てて下さい
LEDをP0[5] に割り当てて下さい
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Step 7 ソースコードの記述

main.cをダブルクリックして開いて下さい

Pinコンポーネントは初期化の必要がないため、
このプロジェクトではソースコードの変更は
必要有りません
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Step 8 Build : Project のビルド
1.Build>Build GPIO_35D を実行

もしエラーが発生したら、
Notice List をクリック

赤のXマークのある
行をクリックすると
エラー発生箇所に
ジャンプします。

エラーが発生した
場合はデバッグして

ください



© Renji Mikami – 2012 PSoC 5 / 3 CUA Workshop 

Step 8.1 ビルド結果の確認

“---- Buid Suceeded: **/**/**** **:**:** ---” と表示されたらBuild成功です

もし、Output画面が見つからない場合は、
Window > Reset Layoutを実行して下さい
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Step 8.2 デバイスへの書き込み動作の確認

2.Debug>Program(Cntl+F5) を実行

1.基板の隅のほうのUSB端子にケーブル接続

こちらは
通信用USB

1.USBケーブルの接続を確認

実際の開発では、デバッグを先に行い、その後でプログラム(書き込み)します
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Step 8.3 デバイスへの書き込み
USBケーブルが 基板とPCに繋がっていることを確認して
から、
Debug > Programを実行して下さい

正常に書き込みが完了しますと、
Output画面に下記のメッセージが表示されます

Device ‘**************’ was successfuuly
programmed
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Step 8.4 基板・ジャンパ接続

P0[5] （下の列）
にジャンパを接続

LED1にジャンパ を接続

SW2 (P6[1])
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Step 8.5 動作確認

補足:
SW と LED の間に

Not Component ( Digital > Logic ) を
挿入することで正論理となります

完成済みプロジェクトは、
¥Lab1¥Lab1_1_Complete にあります。

LEDLED

スイッチを押すとLEDが消灯します。
スイッチを離すとLEDが点灯します。(負論理)

スイッチを押すとLEDが消灯します。
スイッチを離すとLEDが点灯します。(負論理)
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プロジェクト・ワークスペースの複製 1
プロジェクトGPIO_35Dを選択、File>Save XXXX As

続いてGPIO_35Dの
プロジェクトを複製し

GPIO_35Pの
プロジェクトを作ります
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プロジェクト・ワークスペースの複製 2
プロジェクトをGPIO_35Pという名前でセーブしてください
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プロジェクト・ワークスペースの複製 3
File > Close Workspace でワークスペースを閉じてください。
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プロジェクト・ワークスペースの複製 4

ここに
ファイル
が

ないこと
を確認

新しい
GPIO_35P
プロジェクトが
できていることを
確認
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プロジェクト・ワークスペースの複製 6
File >Open
>Project/Workspaceで
複製されたGPIO_35P
プロジェクトを開きます
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プロジェクト・ワークスペースの複製 7
GPIO_35P-0000
という名前のワーク
スペースが自動生成
されます

その中にGPIO_35P
名のプロジェクトが複製
されます

デバイスをPSoC5から3に変える場合では、
Generated_Source内のサブディレクトリが

PSoC5のままになります。
PSoC3への変更は、Generate Configを

実行してください
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GPIO_35Pプロジェクトの目的
• ハードウェア直結からMPU制御に変更(GPIO_35P)

• GPIO_35Pは、ポーリング方式
• プロジェクトの内容

– スイッチを押すとLEDが点灯
– スイッチを離すとLEDが消灯

• 複製したGPIO_35Pプロジェクトをロードして開始します

GPIO_35D

PSoC3/5

P0[5] LEDSW2 (P6_1)

GPIO_35P

PSoC3/5

SW2 (P6_1) P0[5] LED
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TopDesign.cyschを開き、回路図を以下のように表示して下さいTopDesign.cyschを開き、回路図を以下のように表示して下さい

Step 1 回路図エディタの操作1

コマンド ショートカット

拡大 Ctrl + クリック
範囲拡大 Ctrl + ドラッグ
縮小 Ctrl + Shift + クリック
範囲縮小 Ctrl + Shift + ドラッグ
パン(画面移動) Alt + ドラッグ

複製したGPIO_35Pの
プロジェクトをロード
して作業を開始します
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Step 2 回路図エディタの操作2
SWとLEDの間にある配線を削除して下さい。
不要な配線は、選択し、Delete キー を押すこと

で削除できます。
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配線の削除ではエラーが表示されます
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Step 3 SWコンポーネントの設定変更

①コンポーネント SW をダブルクリック

②Digital Input チェックボックスの下にある、
HW Connection のチェックボックスをクリアして下さい

設定が終わったらOKボタンを押して下さい
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Step 4 LEDコンポーネントの設定変更

①コンポーネント LED をダブルクリック

②Digital Output チェックボックスの下にある、
HW Connection のチェックボックスをクリアして下さい

設定が終わったらOKボタンを押して下さい
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設定変更でエラーが消えます
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Step 5 ソースコードの編集

① main.c を開いて下さい ②以下のコードを追加して下さい

if(SW_Read()){
LED_Write(0);

} else {
LED_Write(1);

}
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Step 6 ソースコードの解説
#include <device.h>

void main()
{

for(;;)
{

if( SW_Read() ){
LED_Write(0);

} else {
LED_Write(1);

}
}

}

APIの解説
uint8 Pin_1_Read( void )
•ピンコンポーネントの現在の状態を読み込む

void Pin_1_Write( uint8 value )
•ピンコンポーネントに値を書き込む

追加分
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Step 7 プロジェクトのビルド

作業が完了しましたら、
Build > Build XXXX 
( XXXX は現在のプロジェクト名)
を実行して、
プロジェクトの
ビルドを行って下さい。
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Step 8 ビルド結果の確認

“---- Buid Suceeded: **/**/**** **:**:** ---” と表示されたらBuild成功です

もし、Output画面が見つからない場合は、
Window > Reset Layoutを実行して下さい
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Step 9 デバイスへの書き込み
USBケーブルと基板の接続を確認して、
Debug > Programを実行して下さい

正常に書き込みが完了しますと、
Output画面に下記のメッセージが表示さ
れます

Device ‘**************’ was 
successfuuly programmed
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Step 10 動作確認

P0[5] （下の列）
にジャンパを接続

LED1にジャンパ を接続

SW2 (P6[1])

こんどは、
押すと点灯します
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GPIO_35I プロジェクトの目的
このプロジェクトでは、割り込みを用いたIO制御を行います

プロジェクトの内容
•GPIO_35PプロジェクトをGPIO_35Iに複製します
(GPIO_35Pのプロジェクトの資料を参考にしてください)
•複製したGPIO_35Iプロジェクトをロードして開始します

GPIO_35I用にソースを修正します
•スイッチを押すとLEDが点灯
•スイッチを離すとLEDが消灯

GPIO_35Pの
プロジェクトを複製し

GPIO_35Iの
プロジェクトを作ります
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TopDesign.cyschを開き、回路図を以下のように表示して下さいTopDesign.cyschを開き、回路図を以下のように表示して下さい

Step 1 回路図エディタの操作1

コマンド ショートカット

拡大 Ctrl + クリック
範囲拡大 Ctrl + ドラッグ
縮小 Ctrl + Shift + クリック
範囲縮小 Ctrl + Shift + ドラッグ
パン(画面移動) Alt + ドラッグ

複製したGPIO_35Iの
プロジェクトをロード
して作業を開始します
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Step 2 SWコンポーネントの設定変更

SWコンポーネントをダブルクリックして設定画面を開き、
Pins > Input > Interrupt: を BothEdgesに設定して下さい
設定が完了したらOKボタンを押して下さい
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Step 3 コンポーネントの追加

System > Interrupt コンポーネントを追加し、
図のように結線して下さい

System > Interrupt コンポーネントを追加し、
図のように結線して下さい
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Step 4 ソースコードの編集

②図のようにコードを追加して下さい。
追加するコードについては
次のページに説明があります。

① main.c を開いて下さい
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Step 5 ソースコードの解説
#include <device.h>

CY_ISR(sw_isr){
SW_ClearInterrupt();
if( SW_Read() ){

LED_Write(0);
} else {

LED_Write(1);
}

}

void main()
{

isr_1_StartEx(sw_isr);
CYGlobalIntEnable;

for(;;)
{
}

}

CY_ISR( MyISR)について
•PSoC Creator では CY_ISR というマクロが割り込みル
ーチン用に用意されています。左のように記述することで、
割り込みルーチンを生成できます。

void Pin_1_ClearInterrupt(void)
•Pinコンポーネントの割り込み出力はレベル出力なので、
割り込みが発生するたびにクリアする必要があります

追加分

追加分

ISR_StartEx(cyisraddress addrss)
•ISRコンポーネントの初期化、引数で指定した割り込みル
ーチンのセット、及びその割り込みをEnableします
CYGlobalIntEnable
•デバイス全体の割り込みをEnableします
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Step 6 プロジェクトのビルド

作業が完了しましたら、
Build > Build XXXX 
( XXXX は現在のプロジェクト名)
を実行して、
プロジェクトの
ビルドを行って下さい。
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Step 7 ビルド結果の確認

“---- Buid Suceeded: **/**/**** **:**:** ---” と表示されたらBuild成功です

もし、Output画面が見つからない場合は、
Window > Reset Layoutを実行して下さい
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Step 8デバイスへの書き込み
USBケーブルと基板の接続を確認して、
Debug > Programを実行して下さい

正常に書き込みが完了しますと、
Output画面に下記のメッセージが表示さ
れます

Device ‘**************’ was 
successfuuly programmed
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Step 9動作確認

P0[5] （下の列）
にジャンパを接続

LED1にジャンパ を接続

SW2 (P6[1])

SW2を押すと
点灯します
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GPIO – I/O割り込み
• GPIOポート毎に保有:
• Port Interrupt Control Unit (PICU)
• 専用の割り込みベクタ

• Interrupt on:
• Rising edge
• Falling edge
• Any edge

• Status Register
• どのピンによってI/O割り込みが発
生したかをラッチする

• ファームウェアによる読み出し可能
• 読み出しによるクリア
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GPIO – アナログI/O機能
• 全てのピンがアナログ入出力に
利用可能

• ピン毎に２種の異なる内部接続
• Analog Global Bus
• Analog Mux Bus

• いくつかのピンは特別な機能を
実現するための内部接続を持つ
(P0[0], P0[1], P3[6], P3[7])

• Opamps
• High Current DAC mode

• CapSense Touch Sensing
• LCD char/segment drive
• Hardware controlled analog 

mux at pin 
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SIO (Special I/O) 機能
•入出力電圧とドライブ能力の異なるGPIO
• Vddaに左右されない5.5V tolerant機能

•ホットスワップ
•過電圧耐性

• 入出力電圧レベルを調整可能
• DAC出力
• High Speedコンパレータ入力

• Logic level max current
• 25 mA sink
• 4 mA source

• Pin max current
• ~50 mA sink
• ~25 mA source

• No Analog
• No LCD char/segment drive
• No CapSense touch sensing

5K
Drive Mode 0

Data Register

5K

PIN

Digital Output Path

Digital Input Path

Slew 
Cntl

Slow Slew Enable

Drive Mode 1
Drive Mode 2

Digital Output
0

1

Data Register Bypass

Bidirectional Enable
Bidirectional Control

Interrupt Controller

Digital Input

Pin Status Register

CMOS or LVTTL

Buffer DisableInterrupt 
Logic

Pin Interrupt Type Register

Pin Interrupt Status Register

Driver
Vhigh

Programmable Output Buffer Configuration

Programmable Input Buffer Config Buffer 
Thresholds

Drive
Logic
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課題演習

演習時に指示します



© Renji Mikami – 2012 PSoC 5 / 3 CUA Workshop 

Lab GPIO_35

終了
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Memo

• フォローアップURL
• http://mikamir.web.fc2.com/?/?.htm
• ?に入る文字列は、講義中に示します。

• 担当講師
• ミカミ設計コンサルティング

• 〒142-0042 東京都品川区豊町 2-17-8

• 三上廉司(みかみれんじ) 
• Renji_Mikami@nifty.com
• http://homepage3.nifty.com/western/mikamiconsult.htm
• 電話 080-5422-2503(au)


