
1© Renji Mikami – 2012 PSoC 5 / 3 CUA Workshop 

Renji Mikami
Renji_Mikami@nifty.com

DMAを使用したサイン波生成

DAC Signal Generation
With DMA Control
PSoC 3/5 Experiment
Lab

DAC Sine Wave Generation by Constant Table
Experiment Course Material 4.1 V1.50
June 25th. 2012
DMA_DAC_35.PPT (39 Slides)

44.1

© Renji Mikami – 2012 PSoC 5 / 3 CUA Workshop 



2© Renji Mikami – 2012 PSoC 5 / 3 CUA Workshop 

DMA_DAC_35
DACサイン波信号生成(DMA使用)

DMAC使用

PSoC5版、PSoC3ではメモリアドレスの相違のため一部コードの書換要
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補足:
Workspaceと
Projectの関係

演習ファイルと使用文字などの注意事項

各演習プロジェクトを置くための演習用ディレクトリを作成してく
ださい。場所と名前は、演習中に指示します。(デフォルトは、
C:¥PSoC5_Lab )
設計例(正解の例)プロジェクトは、演習で指示する場所の
PSoC_Lab_MasterXXXXにあります。
使用するファイルのあるディレクトリのパス名に英数字以外の
文字が含まれていないことを確認してください。(不可例参照)
ファイル名、プログラムのソースには、英数字と構文で許され
た記号以外は使用しないでください。(不可例参照)
WorkspaceとProjectを1対1に対応して作成(次スライド)

不可例:全角文字、日本語文字、半角カナ
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演習プロジェクト作成のグランドルール

設計は、プロジェクトをひとつの単位としますが、大規模設計では複数のプロジェ
クトをまとめて、ひとつのWorkspace内で管理することができます。

複数のプロジェクトを一つのWorkspaceに追加した場合、同じ名前のファイルを開
いたときに、どのプロジェクトに含まれるものなのかを毎回確認する必要がありま
す。例えば main.c などです。
ワークショップ中は、この混乱をさけるために、一つのWorkspace には一つのプ
ロジェクトしか配置しないように注意して下さい。

この方法は三つあります。

1.新プロジェクトを作成する前に、一度現在のPSoC Creatorを閉じる
2.プロジェクト作成する前に、FileメニューからClose Workspaceを実行して現在
開いているWorkspaceを閉じる
3.新規プロジェクトを作成する時、Advancedオプション内のWorkspaceをCreate 
New Workspaceに設定する。この方法については次のページに説明があります。
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プロジェクト新規作成時の注意事項
プロジェクトを既に開いた状態で新規プロジェクトを作成した場合、デフォルトでは、
現在開いているWorkspaceに追加されます。ウィザード内のWorkspaceをCurrent 
New Workspaceに切り替えて下さい。

Advancedオプションを
オープンする

Add to Current Workspaceを選択
すると
現在開いているWorkspace内に
新規プロジェクトが作成されます。
Create New Workspaceを選択する
と、
新規Workspaceが作成され、
その中に新規プロジェクトが作成され
ます。
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PSoC Creator では、Workspaceの中に複数の
Project Filesが含まれる、というファイル構成に
なっています。

これは、関連するプロジェクトを一つにまとめて取
り扱うことが出来るようにするものです。例えば以
下のような場合に便利です。

送信側プロジェクトと受信側をひとまとめにして管
理したい時

コンポーネント毎の挙動を確認するためにテストプ
ロジェクトを作成する時

プロジェクトファイルの形式

Workspace(.cywrk)

Project 1 (.cyprj)
•回路図
•main.c

Project 2 (.cyprj)
•回路図
•main.c

Project 3 (.cyprj)
•カスタムコンポーネン
ト

解説
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新規プロジェクトを作成した場合
Creatorを起動した直後に”hoge”という新規プロジェクトを作成し
た場合、自動的に”hoge”というWorkspaceが生成され、その中
に”hoge”というプロジェクトが生成されます(左図参照)。
既にプロジェクトファイルが開かれた状態で、新規プロジェク
ト”piyo”を作成した場合、デフォルトではWorkspace ”hoge”の中
にプロジェクトファイル”piyo”が作成されます。

プロジェクト”hoge”のみ ”piyo”を追加した後 Project “piyo”がWorkspace ”hoge”
の中に追加されました。
プロジェクト名が太字になっているもの
がActiveなプロジェクトです。この場合
は”piyo”がActiveなプロジェクトです。
一つのWorkspace内では常に一つの
プロジェクトがActiveになります。
Creatorからデバイスへの書き込み、デ
バッグの開始などは常にActiveなプロ
ジェクトに対して行われます。

解説
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Buildメニューの変化

この三つの項目 ~~ All Projects
はWorkspace内の全てのプロ
ジェクトが対象になります

この三つの項目は現在Activeな
プロジェクトが対象になります

複数のプロジェクトが一つのワークスペースに含まれている場合、
Buildメニューで、Buildするプロジェクトを選択できるようになります

複数のプロジェクトが一つのワークスペースに含まれている場合、
Buildメニューで、Buildするプロジェクトを選択できるようになります

解説
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Activeなプロジェクトの切り替え方
Workspace Explorer内のプロジェクト名を右クリックし、 [ Set 
As Active Project ]を選択することで、Active Projectが切り替
わります。

解説
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DMA_DAC_35 ラボの目的

• DMAの使い方
• DACの使い方
• 定数テーブルによるサイン波発生

前のプロジェクトをセーブし、
File>Close Workspace で
終了してから、次のプロジェクト
に進みます。

この
エリアに
ファイルが
ない
ことを
確認する
こと

プロジェクトをロードして再開する場合は、
File>Open>Project/Workspaceを実行
続いて、プロジェクト/ワークスペースを選択

作業を終了する場合には、

File>Close Workspace
を実行して現在開いている

Workspaceを閉じること
DMA_WAVE_35.cywrk

注意事項：このラボはのPSoC5(32bit ARM)搭載の
050基板で動作します。PSoC3(8bit 8051)搭載の

030基板ではメモリ構成に合わせてコードを変更します
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8CKIT-030基板での実測 (PSoC3)
DMA_DAC (実測P0[0]) PSoC3

TDS 3054 500MHz/5Gsps
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DMA制御参考コード

uint8 wave[100] = {
128, 136, 144, 152, 160, 167, 175, 182, 189, 196, 203, 209, 215, 221, 226,
231, 235, 239, 243, 246, 249, 251, 253, 254, 255, 255, 255, 254, 253, 251,
249, 246, 243, 239, 235, 231, 226, 221, 215, 209, 203, 196, 189, 182, 175,
167, 160, 152, 144, 136, 128, 120, 112, 104, 96, 89, 81, 74, 67, 60,
53, 47, 41, 35, 30, 25, 21, 17, 13, 10, 7, 5, 3, 2, 1,
1, 1, 2, 3, 5, 7, 10, 13, 17, 21, 25, 30, 35, 41, 47,
53, 60, 67, 74, 81, 89, 96, 104, 112, 120

};

/* Variable declarations for DMA_1 */
/* Move these variable declarations to the top of the function */
uint8 DMA_1_Chan;
uint8 DMA_1_TD[1];

/* DMA Configuration for DMA_1 */
#define DMA_1_BYTES_PER_BURST 1
#define DMA_1_REQUEST_PER_BURST 1
#define DMA_1_SRC_BASE (CYDEV_SRAM_BASE)
#define DMA_1_DST_BASE (CYDEV_PERIPH_BASE)
DMA_1_Chan = DMA_1_DmaInitialize(DMA_1_BYTES_PER_BURST, 
DMA_1_REQUEST_PER_BURST, 

HI16(DMA_1_SRC_BASE), HI16(DMA_1_DST_BASE));
DMA_1_TD[0] = CyDmaTdAllocate();
CyDmaTdSetConfiguration(DMA_1_TD[0], sizeof(wave), DMA_1_TD[0], 
TD_INC_SRC_ADR);
CyDmaTdSetAddress(DMA_1_TD[0], LO16((uint32)wave), 
LO16((uint32)VDAC8_1_Data_PTR));
CyDmaChSetInitialTd(DMA_1_Chan, DMA_1_TD[0]);
CyDmaChEnable(DMA_1_Chan, 1);
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DMA初期化ファンクションの意味
txDmaChan = TxDMA_DmaInitialize
・ バーストコンテンツ：DMAの転送を1byteずつに設定。最大で127要素まで転送可能
・バーストが終わった後のリクエストをハードウェアから出すかどうかの設定
・ソースア ドレスとデスティネーションアドレスの設定。ここでは上位16bitのみが設定される。両方とも
SRAM上なら0x00
txTd[0] = CyDmaTdAllocate();
・ Tdを確保。この値がInvalidだと確保に失敗しているので待機する必要がある。
CyDmaTdSetConfiguration(txTd[0], sizeof(buffer), txTd[0], TD_INC_SRC_ADR);
Td の設定。
・対象となるTd
・Tdで転送するbyte数
・別にTdを選択する場合には、ここにほかのTdをセットする。
・ アドレスのインクリメントおよび転送終了の有り、無しを選択

CyDmaTdSetAddress(txTd[0], LO16((uint32)buffer), (uint16)I2S_Tx_dpTx_u0__F0_REG);
・ Tdを選択
・データの転送元アドレスを設定
・データの転送先アドレスを設定

CyDmaChSetInitialTd(txDmaChan, txTd[0]);
確保したTDに対して、最終的に関連づけを行う。

CyDmaChEnable(txDmaChan, 1);
最後にチャンネルをイネーブルにする。
・1だと転送完了後に自動的に設定が初期化される。0だとそのまま。
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Step1.PSoC Creator Softwareの起動

1.PSoC Createrの起動は、
>すべてのプログラム>Cypress
>PSoC Creater 2.X> PSoC Createrのクリック。2.この

エリアに
ファイルが
ないことを
確認する
こと

前のプロ
ジェクトが
表示される
場合は、

File>Close 
Workspace
でクローズ
する。
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各ウィンドウの説明

ウィンドウ番号 機能

1,Main Window 回路の表記、ピンアサイン、コードの記述などを行います。Work space exploreから開いたものが、メイン
ウィンドウに表示されます。立ち上がった状態(画面の状態)ではSchimatic Windowが表示され回路の表
記Windowが表示されています。機能ごとに TAB形式で開かれ、TABが二つ以上ある場合にはTABを右
クリックしてNew XXX windowを選択することで縦、横に分割することもできます。

2,Work Space Explore SourceTABにはプロジェクトに必要なファイルが表示されます。また、ここから既存のファイルを追加する
なども可能です。Componentsには自分で作成したモジュールなどのファイルが表示されます。Resultには
各種ログファイルが表示されます。

3,Component Catalog 標準ではCypress社の用意したモジュールが表示されます。コンポーネントのデータシートなども、ここから
参照できます。

4,Output 現在進行中のLogファイルがここに表示されます。コンパイル結果なども同様に、Output Windowに表示さ
れます。

画面が見つからない場合等は、
Window > Reset Layoutを実行
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Step2.新しいプロジェクトの作成
File->New->Projectを選択してください
Project名は、DMA_DAC_35等にしてください
Locationは、演習で指示しますが、デフォルトは、
C:¥PSoC5_Labとします。
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1.Advanced の前の
+マークをクリックして展開

Step2.1 新しいプロジェクトの設定（続き）

a

2.Empty PSoC5 Designを
クリックしてハイライト表示

3.DMA_DAC_35を
プロジェクトのNameに入力

4.Locationをデフォルトの
C:¥PSoC5_Labに指定

5.デバイスをCY8C-KIT-050
実装デバイスの
CY8C5588-AXI-060に指定
デバイスリビジョン は
2011年Q4 時点では、ES1です。
（デバイス変更は次スライド参照）

6.OKをクリック
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Device Selector デバイスの選択や変更
このアイコンをクリックすると、

表示するフィルタ項目を設定できます

フィルタ項目を選択することで、
必要な機能を搭載した
PSoC を抽出できます

オンライン版もあります
http://www.cypress.com/?id=2232

CY8C-KIT-050 実装デバイスは、
CY8C5588-AXI-060です。
デバイスリビジョン はここで選択できます。
ここから適切ものを選択して下さい

2011年Q4 時点では、ES1です。
使用するコンポーネントには、バージョ
ンがあり、デバイスリビジョンに対応す
るバージョンを選択してください。
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Step3. VDAC8コンポーネントを追加

1.左側のWorkspace Explorerから、
TopDesign.cysch をクリックして
メインWindow(回路図)を開きます

2.右側のComponent Catalogウインドウ
のDAC内から、Voltage DACを選択し、

MainWindowにドラッグ
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Step3.1 DMA, Clockコンポーネントを追加

2.右側のComponent Catalogウインドウ
のSystem内から、Clockを選択し、

MainWindowにドラッグ

1.右側のComponent Catalogウインドウ
のSystem内から、DMAを選択し、

MainWindowにドラッグ
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Step3.2 Pinコンポーネントを追加

1.右側のComponent Catalogウインドウの
Ports and Pins内から、Analog Pinを選択し、

MainWindowにドラッグ

2.Pin_1を右クリックして、
Shape > Flip Horizontalを実行

ピンを左右反転
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Step3.3 VDAC8のコンフィグレーション

VDAC8のシンボルをダブルクリックして
コンフィギュレーション設定
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Step3.4 DMACのコンフィグレーション

DMACのシンボルをダブルクリックして
コンフィギュレーションを設定、確認
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Step3.5 Clockのコンフィグレーション

Clockのシンボルをダブルクリックして
コンフィギュレーションを設定、確認
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Step4 コンポーネントの配線

ワイヤーツールを選択して配線
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Step5デバイスのピンアサイン
左側のWorkspace Explorerから、DMA_DAC_35.cydwr をクリック、

画面下左端のPinsを選んでピンアサイン画面が開く。

下向きの三角マークをクリック
ドロップダウンリストから

P0[0]を選択
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Step6.main.cにコードを記述(その１)

#include <device.h>
uint8 wave[100] = {

128, 136, 144, 152, 160, 167, 175, 182, 189, 196, 203, 209, 215, 221, 226,
231, 235, 239, 243, 246, 249, 251, 253, 254, 255, 255, 255, 254, 253, 251,
249, 246, 243, 239, 235, 231, 226, 221, 215, 209, 203, 196, 189, 182, 175,
167, 160, 152, 144, 136, 128, 120, 112, 104, 96, 89, 81, 74, 67, 60,
53, 47, 41, 35, 30, 25, 21, 17, 13, 10, 7, 5, 3, 2, 1,
1, 1, 2, 3, 5, 7, 10, 13, 17, 21, 25, 30, 35, 41, 47,
53, 60, 67, 74, 81, 89, 96, 104, 112, 120

};

正弦波の100ポイントのデータの記述 (ペーストソースあり)
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Step6.main.cにコードを記述(その2)

void main()
{

/* Variable declarations for DMA_1 */
uint8 DMA_1_Chan;   //チャネル定義
uint8 DMA_1_TD[1];   //チャネルTD定義

/* 定数の設定 */
#define DMA_1_BYTES_PER_BURST 1  

//1バーストあたり1バイト転送
#define DMA_1_REQUEST_PER_BURST 1  

//バーストごとに転送リクエスト
#define DMA_1_SRC_BASE (CYDEV_SRAM_BASE)

//転送元ソースのアドレス
#define DMA_1_DST_BASE (CYDEV_PERIPH_BASE)

//転送先ディスティネーションのアドレス
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Step6.main.cにコードを記述(その3)
/* DMA Configuration for DMA_1 */
DMA_1_Chan = DMA_1_DmaInitialize(

DMA_1_BYTES_PER_BURST, DMA_1_REQUEST_PER_BURST, 
HI16(DMA_1_SRC_BASE), HI16(DMA_1_DST_BASE)); 
//( 1, 1, 0, 1)

/* TDのアロケーション */
DMA_1_TD[0] = CyDmaTdAllocate();

/* TDのコンフィギュレーション(引き数) */
CyDmaTdSetConfiguration(DMA_1_TD[0], sizeof(wave), 

DMA_1_TD[0], TD_INC_SRC_ADR);

/* CyDmaTdSetAddress(td,転送元下位16bitアドレス.
転送先下位16bitアドレス) */

CyDmaTdSetAddress(DMA_1_TD[0], LO16((uint32)wave), 
LO16((uint32)VDAC8_1_Data_PTR));

/* DMAチャネルとTDのイニシャライズ */
CyDmaChSetInitialTd(DMA_1_Chan, DMA_1_TD[0]);

/* DMAチャネルのイネーブル化 */
CyDmaChEnable(DMA_1_Chan, 1);}
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Step6.main.cにコードを記述(その4)

/* Start the DAC */
VDAC8_1_Start();

/* CyGlobalIntEnable; */
/* Uncomment this line to enable global interrupts. */
for(;;)
{        

// DMA runs continuously without CPU intervention
}

}

DMAとコードの解説は、CS_HWA_XXXX.PPT 資料を参照してください。
このコードは、PSoC5用です。
PSoC3用のコードの解説は、上記資料にあります。
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Step6.Buildの実行

2.もしエラーが発生したら、
Notice List をクリック

3.赤のXマーク
のある行を
クリックすると
エラー発生箇所
にジャンプ

1.Build > Build プロジェクト名
を実行
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エラー発生時には、修正して再度Build

Build -> Build XXX(XXXはプロジェクト名)を選択して
Buildを再実行
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Step7.デバイスにプログラムを書き込み
Debug->Programを選択
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プログラムの進行

プログラムの進行状況はOutputウインドウに表示
正常に終了した場合はSucessfully programmed…と表示されます

各演習プロジェクトが終了時には、必ず現在のワークスペースを閉じてから
( File>Close Workspace )次のプロジェクトの作成や読み込みを行ってください。
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プロジェクト/ワークスペースのクローズについて

この
エリアに
ファイルが
ない
ことを
確認する
こと

1.File > Close Workspaceを実行

プロジェクトをロードして再開する場合は、
File>Open>Project/Workspaceを実行
プロジェクト/ワークスペースを選択
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オシロスコープ(WS)で波形の観測
DMA_DAC (実測P0[0])

TDS 3054 500MHz/5Gsps
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オシロスコープやWave Spectra等がない場合には、周波
数を1から10Hzに落とし、電圧のスイングを0から5Vに上げ
て、LEDの点灯で確認します。2箇所のパラメータの変更で、
周波数とスイング電圧を変更します。

1.スライド22 Step3.3 のRengeの変更
2.スライド24 Step3.5 のClock Frequency の変更
各自で変更し、LEDでサイン波の明暗変化を確認して
ください

課題演習
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Lab DMA_DAC_35

終了

この資料は、デバイスがES1, 
ソフトウェアPSoC Creater 1.0SP2 /2.0

をベースに作成しています。

エラッタやバージョンの違いで操作や動作が

異なる場合があります。

セーブ後は、File>Close Workspace で終了します。
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